[▲前のスレッド]

[8209] sakuraの対応バージョンについて。返信 削除
2016/11/12 (土) 19:37:40 ばぼ
Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko
トップページのバージョン記述についてのいちゃもんです。

> Ver. 1.x.x.x(ANSI版) ではMS Windows (95)98/NT/2000/XP/Vista/7/8の日本語版が必要です.
> Ver. 2.x.x.x(Unicode版) ではMS Windows 2000/XP/Vista/7/8が必要です.


v1系
・win98は「98SE」と書くべきなはず。
・「NT」って書き方だと「すべてのNT」に見えます。
 WinNT2.0以前はそもそも「Windows」じゃないので、動かないはず。
 WinNT3.0以降はWin9x系の上位互換なので、98で動くなら動くはずです。
・vista以降のwindowsはxpの上位互換です。
 セキュリティリスクでもない限りxpで動くならvistaでも動きます。
 vista特有の機能に対応しないなら「vista対応」を名乗るべきじゃないと思います。。。

v2系
・win2k以降はOS自体が国際対応してますが、
 日本語フォントがないと文字化けしますよね。
・vista以降の...(v1系と同じなので省略)


まとめると↓ということです。

Ver. 1.x.x.x (ANSI版) ではMS Windows 98SE以降の日本語OSが必要です.
Ver. 2.x.x.x (Unicode版) ではMS Windows 2000以降のOSが必要です.
 ただし、日本語の表示には日本語フォントのインストールが必要です。

このほうがスッキリしますよね?
vista以降に関する「嘘」もなくなりますし。

まぁ、利用できるもの全部書く方針なら、
windows 10についての記述も追加すべきだと思います。

うちの win10pro(64bit) では、ちゃんと動いてますからね。

[▼次のスレッド]
INCM/CMT
Cyclamen v3.81